Edit Order now returns 404


Recently (perhaps since a week) I am receiving a 404 from /api/v3/brokerage/orders/edit/ as per Coinbase Cloud.

Interestingly if I send a dud payload, I get the below:
‘{“error”:“unknown”,“error_details”:“proto:\xa0(line 1:2): unknown field \“huzzah\””,“message”:“proto:\xa0(line 1:2): unknown field \“huzzah\””}’

If, however I send a seemingly valid payload, I get the 404:

    payload = {
        'order_id': order_id,
        'price': str(new_price),
        'size': str(new_size)

My code has not changed and worked previously (verified with repo history). Has something changed?


1 Like

I am seeing same problem:

{"error":"unknown","error_details":"Not found","message":"Not found"}

In addition, the edit preview (/api/v3/brokerage/orders/edit_preview/) works as expected with no errors and the correct (expected) response.

I’m getting this as well

I also find edit_preview returns

  "errors": [
      "edit_failure_reason": "INVALID_EDITED_SIZE"
  "slippage": "",
  "order_total": "",
  "commission_total": "",
  "quote_size": "",
  "base_size": "",
  "best_bid": "",
  "best_ask": "",
  "average_filled_price": ""

if I only specify a new price without also specifying a new quantity, but edit still returns not found even if I specify both.

I tried it with the client_order_id in order_id, but still returns not found

Hey folks. The REST endpoint for edits is currently disabled while we apply and test a fix: Coinbase Status - Edit order via REST API is temporarily unavailable

Sorry for the inconvenience.

Is this some sort of joke? You knock out a core endpoint for ORDER MANAGEMENT and it takes you a week to respond on the forum and 11 days we still cannot edit orders effectively? Are you actively trying to drop users?

I would not call it core endpoint… It was added less then month ago:


  • Added Edit Order which allows users to edit orders. Only limit order types, with time in force type of good-till-cancelled can be edited.
  • Added Edit Order Preview which allows users to preview an edit request’s results. Only limit order types, with time in force type of good-till-cancelled can be previewed for an edit.
  • Added edit_history to response from Get Order, List Orders

What do you think think people are using the API for, dog grooming? I’m glad you have an opinion; the rest of us that are running live systems with order optimization/management strongly “disagree”.

1 Like

@RobV May I ask? Did you have access to that API before it was made public for everyone? Otherwise you surly can manage orders the way you did before this API endpoint was added, no?

Don’t get me wrong - it is disaster. API was available less then month and it is already broken… Their status page shows that this is problem since 1st December. That is not acceptable!

This raises question - can you trust this API at all… They are pushing changes/updates/fixes without any notice.

Anyway good luck running live systems with this API.

Odds on a estimated time for it being restored?

1 Like

@matt_n I am still getting 404 when attempting to edit orders (using https://api.coinbase.com/api/v3/brokerage/orders/edit) The update message on https://status.coinbase.com/ currently says that a fix has been implemented. Is this fix currently not implemented for advanced trade or is the fix not actually as fixy as intended?

This is not fixed, I am also still getting same error.

I am also receiving similar errors related to the v2/accounts endpoint and v2/brokerage/accounts endpoint. This is a massive issue, as you need the account_id these endpoints return in order to make subsequent calls.

1 Like

Hi @RobV! Apologies for the delay. We are working on it. We will let you know as soon as we have an update regarding this. Please allow us some time.

Update: The status page will be corrected to show the issue ongoing status. Our team is informed and they are working on it.

1 Like

Thanks - we need a fix soon! :pray:

Hey folks. Editable Orders APIs are back online.

Apologies for the delay. The issues we were fixing were related to a race condition at high scale, causing some odd behavior that was difficult to replicate. In the interest of accuracy and trust, we took extra time to develop a comprehensive testing framework before launching our fix, and we’re keeping a close eye on this.

Thanks for your feedback!


The edit endpoint is operational. We have pinged someone to resolve the status page incident since I unfortunately don’t have access to edit the message.

1 Like