Stop order type?

So I feel like I’m hijacking this forum. I realize that it’s pretty new, but hey lets get some threads going huh.

Anyway I’m trying to set a pair of stop orders, an entry and a loss. Using the body on in the documentation:

“type”: “stop”,
“side”: “sell”,
“stop”: “loss”,
“time_in_force”: “FOK”,
“post_only”: “false”,
“product_id”: “BTC-USD”,
“stop_price”: “TRIGGER PRICE”,
“price”: “SELL PRICE”,
“size”: “AMOUNT”

Slightly modified of course. I get this error response: {“message”:“Invalid order_type stop”}

Assuming that I should be setting these as limit order because the documentation also says that they are executed as such, and I get an error regarding the time_in_force not being able to be set to fill or kill.

Now I realize my background is way more coding than stock markets. But can someone help me understand what I am doing wrong here?

@cleggink - We truly appreciate your participation and don’t feel like you are hijacking at all! We are building a Forum strategy here at Coinbase and will begin to get some threads going and build momentum soon. In the meantime, please keep asking, please keep helping - we are grateful for your role in the early stages. I will figure out what is happening here - stay tuned…

1 Like

Seems to work fine for me if I set the stop values on a limit order. Like there just isn’t an order type labeled stop. Sounds like an error in the documentation if you want my option.

@cleggink Agreed, the document can be more specific - I have made a note fo the team to review.

Check out Create a new order
As I am sure you’ve gathered, for Order types, they can be either ‘market’ or ‘limit’ … ‘stop’ is not an order type, but rather a sub-order type associated with a ‘limit’ order.

Right, but when you look at the example code it shows the order type as stop, it’s also in the drop down menu to put the example together. Which is why I thought it was an option.

Thanks @cleggink - working to get that doc clearer for all of us.

1 Like