C# API error: authentication failure

I am out of ideas, I’m having an issue with either my credentials or my code with the Coinbase Advanced Trade API when accessing via C#.
I’ve tried 2 separate implementations of the websocket access and am completely stuck on: {“type”:“error”,“message”:“authentication failure”}
I’ve used the Coinbase.AdvancedTrade solution from nuget (GitHub Here) and I’ve used the quick solution posted on the forums which I can’t find anymore, same result.
I have communicated with the coder for Coinbase.Advanced trade package, it definitely works for him. I’ve used both Environment variables and hard coded the keys. I’ve double and triple checked all the formatting and suggestions from the forums here and reddit (get rid of ==, ensure the newline is correctly encoded, get rid of EC, check with JWT.io, etc)
I used to use coinbase.pro apis with no trouble, but this is stumping me.
I’m gonna list the steps I took in case I missed something.

  1. Create API keys at cloud.coinbase.com, create a trading key, leave whitelist blank (also tried whitelisting, not sure I got the formatting right though)
  2. Wait until the key is enabled.
  3. Copy the name field of the API key into an environment variable and later directly into the code as the public key as outlined by the cloud/advanced trade docs.
  4. Copy the secret portion of the API key into an environment variable and later directly into the code as the private key.
  5. Execute the quick example code (Candle websocket example from Coinbase.AdvancedTrade, and just directly implement the code example from the forums).
    I’m using visual studio community on a windows 10 machine, I have a very solid internet connection.
    If anyone has any ideas I’d greatly appreciate them.
1 Like

Hey, man :sunglasses:
I have solution for you:

  1. Don’t use cloud.coinbase.com for API’s keys
  2. Use coinbase.com

1 Like

You are creating Cloud API key but linked library seems to use Legacy API key.

1 Like

SOB, you are correct it was a legacy key issue. Thanks for the help.