Im not sure which is the API key because none of it works in my code

please help me figure out which is the correct key below they key is already deleted I just need to identify it for the next one:
“name”: “organizations/a0a24688-656e-488a-9bcf-cf7e423aba1d/apiKeys/9a2670b1-0a28-4311-9fd9-db20486508c9”,
“principal”: “acf55076-7a33-5c3b-a262-3d6b2d992300”,
“principalType”: “USER”,
“publicKey”: “-----BEGIN EC PUBLIC KEY-----\nMFkwEwYHKoZIzj0CAQYIKoZIzj0DAQcDQgAEyORcDpKCUBShO5hWjKTOdGAnMhv7\nc8O6367r1agGt+0Ij+rrqjyTKi8QmiLO2CI9JfckfzPTfmTjA86Q7aYxfQ==\n-----END EC PUBLIC KEY-----\n”,
“privateKey”: “-----BEGIN EC PRIVATE KEY-----\nMHcCAQEEIKAqCQzS7YJEXccSD2kP0RxysrT2WuyQHlDa8sdg4mvjoAoGCCqGSM49\nAwEHoUQDQgAEyORcDpKCUBShO5hWjKTOdGAnMhv7c8O6367r1agGt+0Ij+rrqjyT\nKi8QmiLO2CI9JfckfzPTfmTjA86Q7aYxfQ==\n-----END EC PRIVATE KEY-----\n”,
“createTime”: “2023-08-14T05:06:11.102877944Z”,
“projectId”: “00000000-0000-0000-0000-000000000000”

Hey @ian_coin, Welcome to the Developer Forum Community!

The keys that you have mentioned above are for your Coinbase Cloud account - However, you have chosen the category as Advance Trade APIs. To retrieve Keys for Advance Trade API, you have to follow below steps on how to create API keys for Advanced Trade APIs.

  1. Sign in
  2. Select Settings from your avatar dropdown.
  3. Select the API tab.
  4. Click New API Key and authenticate.
  5. Choose the accounts (“wallets”) and permissions (“scopes”) that the key should control.
  6. Click Create.
  7. Write down your key and secret! They cannot be recovered!

Please let us if you have any more queries. Thank you!

Sorry but where exactly can you find your key/secret? I can only see something that says “API Key”


I think secret is available only during API key creating… If you did not save it then you will have to create new key.

I have heard this before but I don’t know what people mean by when they say this, all i see when making the api key is the permissions you can set for it. I am very confused right now.

Thanks in advance
Any help very greatly appreciated

I can not verify myself this as I am using security key, but it should work something like this:

  • Click on “New API Key”
  • Select accounts and permissions
  • Click on “Create”
  • There should new window/popup with API Key details. This is where secret should be available. You must copy it now as you won’t be able to see later.

Okay, so that is the “private key” for the api then, correct? One last question, What and where can i find the “public key” for the api then?

Thanks in advance
Any help very greatly appreciated

I have no idea what you mean with public/private keys…

When you generate new API key you will have two things - API Key and API Secret. Both are needed to make API requests. Read the documentation:

Sorry, i did mean the public/private keys, thank you for your help. I tried the below method you listed in the first image and looking at some videos, I should get the two things, API Key and API Secret, but I only get the API Key, as shown in the image. I replicated everything shown in this video but I do not get what he gets, it only shows the API-KEY for me. I tried everything but I still don’t know how to fix

Thank you in advance
Help very greatly appreciated

Are you really creating new API key? API secret is available only once after it is created, once popup is closed there is no way to get secret if you did not save it!

Your screenshot does not include NOTE, that suggest you simply clicked on Show.

Also check this:

1 Like

I finally fixed it!!! What i had to do was disable all my chrome extensions and update my browser then it finally worked

1 Like

Notably, the API secret key is never displayed for users of the Safari browser. Had to download Chrome for this to work. Would be nice if there was some sort of warning.

Edit: …and now I have to wait 48hr for this key to be enabled. Wonderful!