Starting_after cursor is ignored on /charges

Hello team,

The parameter starting_after seems to be ignored by your system so It’s not possible to paginate the /charges endpoint


HI @CharlesRA, thank you for posting your concern here at the Coinbase Developer forum.

To help you with your concern, we would like to ask the following:

  • Have you successfully called any Commerce API endpoint before?
  • Are you also encountering this issue when using the other pagination query parameters such as limit?
  • We are able to paginate the API response when using ISO datetime format on the starting_after parameter but we are also unable to paginate the result when using the resourse ID as a value. Are you also experiencing the same issue?
  • Please send us the code snippet that you are using including the URI. But make sure to remove any sensitive information such as the API key.

We will work to resolve your concern once you have provided answers to our questions above. Thanks!

1 Like
  1. Yes
  2. Yes, I’m also using the limit parameter set to 100
  3. Exactly, previously I was able to use starting_after parameter with the last ressource ID
  4. I don’t think we need a code snippet here:
    According to the documentation:

To get all objects, you need to paginate through the results by always using the ID of the last resource in the list as a starting_after parameter for the next call.

But I get a warning during the http call starting_after ([Uuid ressource]) is not a valid cursor; ignoring'

Hi @CharlesRA! Thank you for providing the information we need. We’ve reported your concern with our internal team and this issue has been fixed. You can now use resource ID as the value for starting_after parameter when paginating the /charges endpoint with no problem.

We hope this helps! If you have questions or clarifications, please do not hesitate to reach out back to us again.

Have a great day!


Thanks Mamoshi27 !