Issue using after in Get all transfers method

How can I use after param in Get all Transfers method?
I tried using ISO 8601, yyyy-MM-ddTHH:mm:ss.fffZ, yyyy-MM-ddTHH:mm:ss and others and nothing worked (using Date 1970-01-01 as a test).
All attempts to use the after parameter just return an empty list. When I remove after param the request return a list of tranfers for me.
What is the right format for the After parameter to work?
Please help us to solve that.
Any help is greatly appreciated.

Hello @glauberfer! Welcome to the forum!

Thank you for providing detailed information. With regard to your query, we tried calling the Get all Transfers method and we were able to successfully get the correct response. You may use this YYYY-MM-DDTHH:MM:SSZ format when using the pagination after parameter for your query to work. You can check this documentation for more details regarding the timestamp format.

Thank you and again welcome to the community!

1 Like

Hi @jewel-ssi,
I Tried this way, but I received this:

When I remove after param:

Is the format wrong?

Hello @glauberfer! We can see that you are inputting a value of 1970:01:01T00:00:00Z, this format is correct. But it looks like you have a misunderstanding regarding the after query parameter. The after parameter references the last item and on the other hand, the before parameter references the first item (you can think of before as start and after as end). So the way you are calling the transfers endpoint, you are searching for the transactions that occurred prior to 1970 and that is why it is returning an empty payload. If you want to search for transactions that occur later than 1970, you must use the before parameter.

To know more information regarding the Pagination parameters, click on this link: Pagination

We hope this resolves your concern. Thank you and have a nice day.