IP does not match IP whitelist

I’m currently running into this error when trying to whitelist the IP’s allowed to access an API key. I’m using a proxy to route the request through the IP addresses that I’ve defined on the whitelist, yet I’m getting this error. Is there any way to check the IP address that Coinbase believes they’re receiving the request from, to help understand what’s causing the error?

I’ve used https://api.ipify.org?format=json and have confirmed that the proxy is routing the request through the correct IP addresses.

Hello @Tradable! We understand the inconvenience you are having. To further assist you with the issue, we’ll need you to provide us the following information:

  • What API endpoint/s are you attempting to use?
  • If possible, can you copy the text of the error message and your sample code? You can also opt to send a screenshot if it’s more convenient for you.

Furthermore, please make sure that VPNs and any other software you may have is not interfering with your IP Whitelisting.

Once you send us the information requested above, we’ll work to quickly address this issue. We appreciate your patience and understanding.

1 Like

Hi @judy.absalon, thanks for getting back to me. Here is the info as requested:

If I use an api key that is not whitelisted, it works fine, so I’m confident that there are no errors in the signature. This request is being made from a cloud backend, so no VPN or software interfering, the proxy is where the request to Coinbase will ultimately be made from. As I mentioned, I made a request to https://api.ipify.org/?format=json and it is returning the correct IP address (one that is on the whitelist).

I have tried other private endpoints such as /accounts, and I get the same error message. Public endpoints of course are working, as I don’t need to authenticate the request.

Hi @judy.absalon, any updates?