Invalid API on buy/sell orders

So I can authenticate and access information which requires a signature to be viewed. Tells me I have permissions and a a valid API to access all my wallets and information etc. As soon as I call my buy/sell function using the same signature, I get an invalid API key error {“message”:“Invalid API Key”}.
without calling the trade function I get
HTTP connection successful!
and then all corresponding information.
Anyone else had this?

Hi @LongTimeListener, welcome to the forum! We understand that you are getting an Invalid API Key error when executing the buy/sell endpoint but successfully calls the /accounts endpoint. We’re happy to help, but first we’ll need you to provide us with the following information so that we can further assist you with the issue:

  • When you mentioned buy/sell function, are you referring to the side: buy/sell body parameter of the Create Order endpoint? If not, please specify.
  • Please provide the code snippet including the URL, body request and parameters that you used to demonstrate the problem you are encountering and kindly ensure to exclude your API credentials for security reasons.
  • Are you also encountering the same error with other endpoints aside from the /accounts endpoint? If yes, kindly specify the other endpoints that you have the same error.

If you have any additional information that can demonstrate your concern, feel free to share it with us.Once you send us the information requested above, we’ll work to quickly address this issue. We appreciate your patience and understanding.

I realized I had made a mistake in my API call so i deleted the screen shots. I corrected the mistake to include my secret key from an external file thinking that was the problem. It did not change.
I am authorized with the API to collect all the information I want about my account and prices, but to buy/sell I am unauthorized. I tried BTC-USD and ETH-USD with the same result.
I have seen others with the same problem on here but there seems t be no answer to get it correct.
I have deleted and created new API combinations, and even when retrieving account info, trading-disabled is false.
…‘trading_disabled’: False, ‘auction_mode’: False, ‘product_type’: ‘SPOT’, ‘quote_currency_id’: ‘USD’,…

Hello @LongTimeListener! Thank you for informing us that this only happens when you buy/sell. This must be inconvenient in your end. Rest assured that we are here to assist you in resolving this issue.

Upon checking, this kind of issue must be addressed discreetly as we might need account related information from you to resolve your concern. We suggest you open a support ticket using the email address associated with your Coinbase account and please include the link to this forum so that the team will know it’s you. Aside from that please share with us the code snippet you are using that includes the URL, body request and parameters. Please exclude any sensitive information such as your API credentials.

Looking forward to hearing from you. Have a great day!

A post was merged into an existing topic: Invalid product_id using /api/v3/brokerage/orders API

I have opened a support ticket.