Incomplete API response (List Transactions Request)

Hello dear Coinbase Cloud Forum!

I am referring to the List Transactions Request: https://api.coinbase.com/v2/accounts/:account_id/transactions

Until recently, a parameter was supplied for the transaction types Buy, Sell and Trade, in which a unique Buy, Sell or Trade ID could be found so that the corresponding counter transaction could be clearly assigned . Without this ID, it is impossible to clearly assign two corresponding transactions from two accounts (e.g. a corresponding BTC/EUR sell in the BTC and EUR account).

Please clarify this issue.

Best regards,
Matthias
cryptomt

We have the same problem!
And even more problems: we are missing fee/commission for all past trades, where we already got a fee in the past.
So I think this endpoint is completely broken after they deprecated some stuff lately:

DEPRECATING SELECT PARAMETERS ON FEBRUARY 7

On 7 February 2024, select parameters for SIWC v2 List Transactions and Show Transaction APIs will be deprecated, and some will be added and updated.

On 31 March 2024, deprecated parameters will be removed entirely for these endpoints.

:white_check_mark: To view the new schema after Feb 7, pass new_version_opt_in in the request url.

We are also not able to get a response with

?new_version_opt_in=1 
?new_version_opt_in=true 
?new_version_opt_in

or how would you interpret the last sentence?

Yes, this is a pity! :sleepy:

List Transactions call with new_version_opt_in=false brings:

{“id”:“f17f01be-5372-52a6-8cba-de61f8f704c8”,“type”:“sell”,“status”:“completed”,“amount”:{“amount”:“-1.82483899”,“currency”:“CGLD”},“native_amount”:{“amount”:“-0.20”,“currency”:“EUR”},“description”:null,“created_at”:“2024-02-07T15:55:47Z”,“updated_at”:“2024-02-07T15:55:47Z”,“resource”:“transaction”,“resource_path”:“/v2/accounts/bc2a4277-0015-5cfe-880f-8464c93dbf74/transactions/f17f01be-5372-52a6-8cba-de61f8f704c8”,“instant_exchange”:false,“details”:{“title”:“Celo verkauft”,“subtitle”:“CGLD Wallet verwendet”,“header”:“1,82483899 CGLD (0,20 €) verkauft”,“health”:“positive”,“payment_method_name”:“CGLD Wallet”},“hide_native_amount”:false}

List Transactions call with new_version_opt_in=true brings:

{“id”:“f17f01be-5372-52a6-8cba-de61f8f704c8”,“type”:“sell”,“status”:“completed”,“amount”:{“amount”:“-1.82483899”,“currency”:“CGLD”},“native_amount”:{“amount”:“-0.20”,“currency”:“EUR”},“description”:null,“created_at”:“2024-02-07T15:55:47Z”,“resource”:“transaction”,“resource_path”:“/v2/accounts/bc2a4277-0015-5cfe-880f-8464c93dbf74/transactions/f17f01be-5372-52a6-8cba-de61f8f704c8”,“sell”:{“total”:{“amount”:“0.20”,“currency”:“EUR”},“subtotal”:{“amount”:“1.19”,“currency”:“EUR”},“fee”:{“amount”:“0.99”,“currency”:“EUR”}}}

There is no such unique sell-id in the sell-subfield, even with new_version_opt_in=true.

I am in contact with support at the same time! Currently I have only been referred to the documentation. I’m still hoping for professional help!

You should be able to see the new schema by passing parameter new_version_opt_in=true

If I add that parameter, I get an “invalid signature” error.