Creating a new API key does not provide SIGNING_KEY

I need to connect to the new advanced trading API, and when I make a new API KEY – it is generated, but nowhere in the prompt do I see a SINGING_KEY. I’ve even tried making a key with one IP restriction and still nothing works. This is very frustrating…

I’ve spent well over 3 days trying to figure this out and no matter how many times I try, the signing key is always missing.

Thanks!

2 Likes

So according to this article, I should actually get an API_KEY and an API_SECRET. The secret key is nowhere to be found when I create a new API key.

Hey @one.insight, Welcome to the forum community!

We’ve tried creating an API Key on our end and we were able to see the API secret, so this issue might be occurring on some users only. We recommend that you try the troubleshooting steps below.If you are experiencing this issue on a desktop computer, please:

  • Update your browser to the latest version.
  • Try reproducing the issue in incognito mode.
  • Clear your browser’s cache and restart your browser.
  • Test if the issue still occurs on a different browser (we recommend Google Chrome).
  • Try signing out of, then back into, Coinbase.

Please note that you will not be able to view your API Secret on your created API Key. It is only during the API Key creation process that you will be able to see its corresponding API Secret. Therefore, we recommend you to create a New API Key on your Coinbase account. After you choose your desired Wallets and Permissions for your API Key, click the “Create” button, a pop-up window will appear containing the API key details (API Key, API Secret, etc.). This is the only time you will be able to view and copy your API Secret.

  • We highly recommend that you take note of these credentials and store them in a safe place. Again, you cannot view your API Secret by clicking ‘Show’ once the pop-up window has already been shown.

We hope this helps. We’d be happy to answer any more questions.

Thank you and have a nice day!

I have the same issue, and I am not able to see the API secret. This is all I see:

API Key details

API Key: [the actual key]

Disabled


Created at: October 19, 2023 16:23
Last updated at: October 19, 2023 16:23

Try Firefox - for some ppl it works in Firefox but not in Chrome.

Sorry about that, there is no passphrase in this architecture.

Thank you for your assistance.

1 Like

There is no passphrase, but you still need a secret – you’re running into a browser bug that a lot of other people have experienced.

Also try incognito mode / private window

I just re-read the title of your post.

The bug where your Secret is not displayed is one thing.

A Signing_Key is a completely different topic, and you need one of those too to make API calls.

You do not get a Signing_Key from www.coinbase.com/settings/api - you make it yourself.

Here is a tutorial from the AT Docs: Advanced Trade REST API Authentication | Coinbase Cloud

Here is a tutorial from the SIWC Docs – I use Axios instead of Request. Sign In With Coinbase API Key Authentication | Coinbase Cloud

The tutorials are /slightly/ different, but the working code you wind up with is the same – you can reuse the same code for both AT & SIWC API calls.

Here are two code examples of signatures working:
Might want to Copy-Paste them, as these links might expire.

GET request https://jmp.sh/h20tkh0V
POST request 7 deposit usd