I am trying to create limit order with below request but unable to create limit order

request_path = “/api/v3/brokerage/orders”
method = “POST”

    payload = {
        'client_order_id':  "Unique_UUID",
        'product_id':  "ADA-USDT",
        'side': "BUY",
            "limit_limit_gtc": {
                "limit_price": "0.25",
                "base_size": "5"

    headers = self._build_request_headers(method, request_path, json.dumps(payload))
    response =, json=payload, headers=headers)

“success” : false,
“failure_reason”: “UNKNOWN_FAILURE_REASON”,
“order_id”: “”,
“message” : “source is not enabled for trading”,

Hi @Firzan! Thank you for taking an interest in trying out Coinbase APIs. For the details regarding your inquiry, we will check on this for you with our team to see how we can best assist. We’ll get back to you once we have more information. Keep in touch!

Hi @Firzan! Thank you for your patience as we look into this. Based on our investigation, this error is usually encountered when the quote wallet asset is not enabled to trade. We suggest that you try checking the details related to the API key you are utilizing for this API call. Such that, the API key should have access to the quote asset wallet that is, in your case, the USDT wallet.

We hope this is helpful, and please let us know if you have any other questions. Have a great day! :sunny:

1 Like